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Converting an Older 

Document to Word 2010 
 
Word 2010 can work with Word documents created in 

earlier versions of Word thanks to its Compatibility 

Mode. When an early version of a Word document is 

opened in Word 2010, Compatibility Mode is 

automatically turned on. This ensures that only features 

that are compatible with earlier versions are available, so 

people still using early versions of Word will still have 

full editing capabilities. 
 

Tips 
 
 When you convert a file, the original file is 

overwritten. If you ever intend on using the original 

file again, save a copy of it in its original file format 

before converting.
 

 In Word 2010, open the document that you want to 

convert. 
 

Converting the file to Word 2010 .docx format 

will make many new features available in the file. 
 

 Click the File tab on the Ribbon. 
 

The Info tab of Backstage view appears. 

 
 Click the Convert button. 

 
The Microsoft Office Word dialog box appears, 

asking you to confirm that you want to convert the 

document. 
 

Tip: The Convert option only appears when 

Word is in Compatibility Mode. 
  

Tip: Select the Do not ask me again about 

converting documents check box if you 

don’t want to see this dialog box in the future 

when converting documents.  
 

 Click OK. 
 

The document is converted, and Compatibility Mode 

is no longer on. 

 

 
 Exercise  

 Exercise File: Old document.doc 
 

 Exercise: Convert the old document to 2010 format.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Figure 16-1: When a document created in an earlier 

version of Word is opened in Word 2010, it is opened in 

Compatibility Mode. To enable all features of Word, 

you’ll need to convert it to Word 2010 format.  
 
 
 
 
 
 
 
 

 
Figure 16-2: This dialog box appears when a document is 

being converted. 
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Translating Text 
 
Translating a document into a different language can be 

a difficult task. Word includes several translation tools to 

make it easier. 
 

Select a translation language 
 
Before you start translating a document, select the 

language into which you want to translate it. 
 

 Click the Review tab on the Ribbon and click the 

Translate button in the Language group. 
 

A list of options appears. 

 
 Select Choose Translation Language from the list. 

 
The Translation Language Options dialog box 

appears. You can select the language that the Mini 

Translator should use or the language you want to use 

to translate an entire document. 
 

 Select the language you want to use and click OK. 
 

You are ready to translate your document into 

the language you selected. 
 

Translate an entire document 
 
If you have an Internet connection, you can use 

Microsoft’s online translation service to translate an 

entire document. 
 

 Click the Review tab on the Ribbon and click the 

Translate button in the Language group. 
 

A list of options appears. 

 
 Select Translate Document. 

 
The Translate Whole Document dialog box 

appears. Confirm that you want to translate the 

entire document. 
 

 Click Send. 
 

Your Web browser appears, displaying the 

translated document. 

 

 
 Exercise  

 Exercise File: Description15-2.docx 
 

 Exercise: Translate a single word in the document 

into French.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Figure 16-3: The Translate button.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Figure 16-4: Select your languages in the 

Translation Language Options dialog box. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Figure 16-5: A document translated into 

another language.  
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Translate selected text   
If you only need to translate a few words or a 

short phrase, you can use Word’s Research pane. 
 

 Select the text you wish to translate. 

The text is highlighted blue. 

 
 Click the Review tab on the Ribbon and click the 

Translate button in the Language group. 
 

A list of options appears. 

 
 Select Translate Selected Text from the list. 

 
The Research pane appears, displaying your 

text beneath the Translation heading. 
 
 You can change the languages Word translates from 

and to by clicking the From and To list arrows in 

the Research pane.
 

Translate a single word 
 
The Mini Translator lets you translate a single word 

by pointing to it with your mouse. 
 

 Click the Review tab on the Ribbon and click the 

Translate button in the Language group. 
 

A list of options appears.  
Figure 16-6: The Research Pane.  

 Select Mini Translator from the list. 
 

You are now ready to use the Mini Translator. 

 
 Point to the word you wish to translate. The 

Mini Translator displays the translation. 
 

Tips 
 
 Click the Play button in the Mini Translator to listen 

to the word’s pronunciation.


 Word’s translation software is not perfect. No matter 

which translation tool you use, always proofread your 

document carefully for any mistakes. 
 
 
 
 
 
 
 

 
Figure 16-7: Use the Mini Translator to translate a single  
word in a document.  
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Publishing a Blog Entry 
 
Blogs have become one of the most popular ways to 

make your voice heard on the Internet. More popular than 

personal Web pages, a blog (Web log) is a Web site 

where entries about an individual’s thoughts are recorded. 

Most are themed for politics, food, or another topic of the 

author’s choice. Others are run more like an online 

journal. 
 

Register a blog service provider with Word 
 
You need a blog provider that hosts and maintains your 

blog before you begin writing blog entries in Word. 
 
Word 2010 works with several blog service 

providers. These providers are listed in Table 16-1: 

Blog Service Providers. 
 
Once you have a blog account with a blog service provider, 

you can register the blog’s information in Word. 
 

Tips 
 
 If you don’t register your blog account in Word, 

you won’t be able to publish entries to your blog 

from Word.
 

Create a blog post 
 
Creating an actual blog entry is not very difficult at all. 

Just use the commands available to you in the Blog Post 

and Insert tabs on the Ribbon and publishing to your 

registered account is a snap. 
 

 Click the File tab on the Ribbon and select New. 

Options for creating a new document appear. 

 
 Select the Blog post under Available Templates 

and click the Create button. 
 

The Word document will convert itself into a blog 

post. You can continue to edit your entry or 

publish your post. 
 

Other Ways to Create a Blog Post:  
Click the File tab on the Ribbon and select Save 

 Send. Select Publish as Blog Post under the 

Save & Send category and click the Publish as 

Blog Post button. 
 

 Enter a Post Title and, if necessary, create your 

blog post entry. 
 

A blog post entry can be any combination of text 

and items you can insert under the Insert tab, such as 

pictures, links, or videos. 
 

When the post is ready, publish it to your blog. 

 

 
 Exercise  

 Exercise File: None required. 
 

 Exercise: Create a blog post. If you wish, register your blog 

service provider with Word and publish the blog post. 
 
 
 
 
 
 
 

 

Table 16-1: Blog Service Providers  
 
 SharePoint blog



 WordPress


 Blogger


 Windows Live Spaces


 Community Server


 TypePad 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Figure 16-8: When the post is completed it can be 

published directly to your blog (as long as your 

blog service is registered with Word).  
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 Click the Publish button in the Blog group. 

The Connect to dialog box appears. 

 
 Click the User Name text box and enter your user 

name. 
 

 Click the Password text box, enter your password, 

and click OK. 
 

The Microsoft Office Word dialog box appears, 

telling you that it may be possible for other people 

to see information such as your blog user name and 

password. 
 

 Click Yes. 
 

A message appears informing you that the blog 

post was published. 
 

Register with another provider 
 
You can register with another blog service provider 

if yours is not listed in Word. 
 
 

 Create a new blog post. 
 

If you have not registered a blog service provider, 

the Register a Blog Account dialog box appears. 
 

 Click Register an Account. 
 

The New Blog Account dialog box appears. 

 
 Click the Blog list arrow and select Other from the 

list. Click Next. 
 

The New Account dialog box appears. The 
information required in this dialog box is available

 Figure 16-9: The registration page at 

Wordpress.com from the blog service provider. 
 

 Type your user name, password, API, and blog 

post URL. Click OK. 
 

Word confirms the information with the provider. 

Once the confirmation process is complete, you can 

begin writing and posting blog entries using Word. 
 

Tips 
 
 If you have multiple blogs, click the Blog Post tab 

and click the Manage Accounts button in the 

Blog group to set a default account, add an 

account, or remove an inactive account. 
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Using Hyperlinks 
 
If you have ever been on the World Wide Web, you’ve 

used hyperlinks to move between different Web pages. 

A hyperlink points to a file, a specific location in a file, 

or a Web page on the Internet or your organization’s 

Intranet. Whenever you click a hyperlink, you jump to 

the hyperlink’s destination. 
 

Tips 
 
 A hyperlink is usually indicated by colored and 

underlined text.
 

Insert a hyperlink 
 
You can insert a hyperlink anywhere in a document. 

 

 Select the text you want to use for the hyperlink. 
 

Hyperlink text is often part of a regular sentence. For 

example, “The Elk Pine Lodge is the premier locale 

for destination weddings in Colorado.” 
 

 Click the Insert tab on the Ribbon and click the 

Hyperlink button in the Links group. 
 

The Insert Hyperlink dialog box appears. 
 

Other Ways to Insert a Hyperlink: Select the 

text to which you want to add a hyperlink and 

press <Ctrl> + <K>. Or, right-click the text and 

select Hyperlink from the contextual menu.  

 

There are four different types of hyperlinks you 

can create: 
 

Existing File or Web Page: Create a link that 

takes you to another Word document or to a file 

created in another program, such as a Microsoft 

Excel worksheet or Web page on the Internet. 

This is the most common type of hyperlink. 
 

Place in This Document: Takes you to 

a bookmark in the same document. 
 

Create New Document: Creates a new Microsoft 

Word document and then inserts a hyperlink to 

the new document. 
 

E-mail Address: Creates a clickable e-

mail address. 
 

 Click the Link to button you want to use. 
 

The dialog box changes to allow you to select 

the destination of the hyperlink. 

 

 
 Exercise  

 Exercise File: Description15-4.docx 
 

 Exercise: Select “North Shore Travel” in the first 

body paragraph. Use it as the text for a link to 

http://www.customguide.com. 
 

Delete the link.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Figure 16-10: Inserting a hyperlink.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Figure 16-11: The Insert Hyperlink dialog box.  
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 Enter information for what you want the hyperlink to 

link to. 
 

Once the hyperlink destination is set, create the link. 

 
 Click OK. 

 

Edit a hyperlink 
 
You can change a hyperlink’s display text, type, 

or destination after it is inserted. 
 

 Right-click the hyperlink and select Edit Hyperlink 

from the contextual menu. 
 

The Edit Hyperlink dialog box appears. You can 

change the type of link, the link’s destination or 

target, or the text that is displayed for the hyperlink. 

 
 Edit the hyperlink and click OK. 

 
The hyperlink is updated with the new information. 

 

Delete a hyperlink 
 
If you no longer want to include a hyperlink in the Web 

page or document, it is easy to remove the hyperlink from 

the text. 

 
Right-click the hyperlink and select Remove 

Hyperlink from the contextual menu. 
 

The hyperlink is removed from the text. 
 

Other Ways to Remove a Hyperlink: Right-

click the hyperlink and select Edit Hyperlink 

from the contextual menu. Click Remove Link 

in the Edit Hyperlink dialog box.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Figure 16-12: Right-click a hyperlink for more hyperlink 

commands. 
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Viewing Document 

Properties and Finding a File 
 
Document properties are bits of information that describe 

and identify a document. This information includes the 

title, author name, subject, and keywords in the document. 

You can also add your own tags to properties to help 

organize and identify the document later. 
 

View document properties 
 

 Click the File tab on the Ribbon and select Info. 
 

The standard document properties appear on the 

right side of the window. You can also view more 

advanced properties. 
 

 Click the Show All Properties link at the bottom 

of the screen. 
 

All document properties are displayed. Once you 

are done viewing and editing document properties, 

you can return to your document. 
 

Tip: To add or change properties, hover your 

pointer over the property you want to update 

and type the information.  
 

 Click the File tab on the Ribbon. 
 

Any changes you made to document properties are 

saved automatically. 
 

Show the Document Panel 
 
You can also view and edit a document’s properties 

by opening the Document Panel. 
 

 Click the File tab on the Ribbon and select Info. 

Information about your document appears. 

 
 Click the Properties button list arrow and 

select Show Document Panel from the list. 
 

The document returns to Normal view, and 

the Document Information Panel appears with 

the document’s standard properties displayed. 
 

 To modify the document’s standard properties, 

click the appropriate field and enter the desired 

information. 
 

The information is modified. You can also view 

more advanced properties. 

 

 
 Exercise  

 Exercise File: Timesheet15-5.docx 
 

 Exercise: View the Timesheet.docx document properties 

and add “Human Resources” to the Tags property. 
 

Search for “times” in the Search box under the Start button.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Figure 16-13: Document Properties appear on the Info tab 

in Backstage view. 
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 Click the Document Properties list arrow in the 

upper-left corner of the Document Panel and 

select Advanced Properties. 
 

The Properties dialog box appears. Use these tabs 

to view and change more document properties. 
 

 Make any changes as necessary and click OK when 

you’re finished. 
 

The Properties dialog box closes. 

 
 Click the Close button in the Document Panel. 

 
The Document Panel closes. 

 

Find a file 
 
It is just as easy to misplace and lose a file in your 

computer as it is to misplace your car keys—maybe 

easier! Luckily, Windows comes with a great search 

feature that can track down your lost files. Search can 

look for a file, even if you can’t remember its exact name 

or location. 
 

 Click the Start button and type what you want to 

search for. 
 

Instant Search looks for file names, file contents, and 

file tags that match the text you are searching for and 

displays the results in the Start menu. 
 

 Click the file that matches your 

search. The selected file appears. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Figure 16-14: The Document Panel.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Figure 16-15: Search results from the Search box in 

the Start menu. 
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Recovering Your Documents 
 
Computers don’t always work the way they’re supposed 

to. Nothing is more frustrating than when a program, for 

no apparent reason, decides to take a quick nap, locks up, 

and stops responding to your commands—especially if 

you lose the precious document that you’re working on! 
 
Fortunately, Microsoft realizes that people might want to 

recover their documents when Microsoft Word locks up 

or stops responding. If Word 2010 encounters a problem 

and stops responding, you can restart Microsoft Word or 

your computer and try to recover your lost documents. 

Sometimes Word will display a dialog box similar to the 

one shown in Figure 16-16 and automatically restart 

itself. 
 

Understand how AutoRecover works 
 
If AutoRecover is enabled in Word, you don’t have to do 

anything to make it work. When Word suddenly crashes, 

Word automatically restarts and returns as close as it can 

to the state of the program as it was. For example, if you 

had several documents open, Word would reopen all the 

documents to the same window size and status before 

the crash. 
 

 Restart Microsoft Word (if it doesn’t restart by itself). 

In a majority of cases, Word will restart on its own. 

 
 Select the best recovered document in the Document 

Recovery task pane. 
 

Sometimes Word will display several recovered 

documents in the Document Recovery task pane, 

such as the original document that was based on the 

last manual save, and a recovered document that was 

automatically saved during an AutoRecover save 

process. You can see the status of any recovered 

document by simply pointing at the recovered 

document for a second or two. 
 

 Click Close to close the task pane. 
 

You can resume working with the document(s). 

 

 
 Exercise  

 Exercise File: None required. 
 

 Exercise: Understand how AutoRecover works. 

Change the AutoRecover save interval to 8 minutes.  
 
 
 
 
 
 
 
 
 
 
 

 

Figure 16-16: This dialog box appears before Word 

closes abnormally (crashes).  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Figure 16-17: The Document Recovery task pane appears 

when Word reappears after closing abnormally. 
 
 
 

 

Table 16-2: Status Indicators in the 

Document Recovery Task Pane 
  
Original Original file based on last manual save. 
 
AutoSaved File recovered during recovery process or file 

saved during an AutoRecover save process.   
Repaired Word encountered problems while recovering 

the document and has attempted to repair them.  
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Change AutoRecovery settings 
 
You can further protect your work by using the 

AutoRecover feature to periodically save a temporary 

copy of the document you're working on. To recover 

work after a power failure or similar problem, you must 

have turned on the AutoRecover feature before the 

problem occurred. You can set the AutoRecover save 

interval to occur more frequently than every 10 minutes 

(its default setting). For example, if you set it to save 

every 5 minutes, you'll recover more information than if 

you set it to save every 10 minutes. Here’s how to change 

the AutoRecover save interval… 
 

 Click the File tab and select Options. 

The Word Options dialog box appears. 

 
 Click the Save tab. 

 
Options for how to customize save settings appear. 

 
 Ensure that the Save AutoRecover information 

every check box is checked and specify the desired 

interval, in minutes, in the minutes box. 
 

You can’t specify the interval if the check box is 

not selected. 
 

 Click OK when you’re finished. 
 

Now Word will automatically save a copy of the 

document at regular intervals as you use Word. 
 

Tips 
 
 Even with Word’s document recovery features, 

the best way to ensure that you don’t lose much 

information if your computer freezes up is to save 

your work regularly.

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Figure 16-18: The AutoRecover options are located in 

the Save tab of the Word Options dialog box. 
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Managing Versions 
 
No matter how many warning dialog boxes Word displays, 

sometimes you close a document without saving it. Word 

makes it easy for users to recover documents that were 

automatically saved using the AutoRecover option. 
 

Tips 
 
 Word stores an unsaved document for four days after 

the document has been closed.
 

Recover new documents 
 
You can recover new documents that you created 

but closed without saving. 
 

 Open Microsoft Word. 

 
 Click the File tab on the Ribbon and select Info. 

Information about the current document is displayed. 

 
 Click the Manage Versions button and 

select Recover Unsaved Documents. 
 

The Open dialog box appears. 
 

Other Ways to Recover an Unsaved 

Document: Click the File tab on the Ribbon, 

select Recent, and click the Recover Unsaved 

Documents button.  
 

 Select the file you want to open and click Open. 

The document opens in a new Word window. 
 

Tip: If you want to save the file, click the 

Save As button in the Info bar. 
 
 

Recover previously saved documents 
 
If you make edits to a saved file then close it without 

saving, you can recover the last autosaved version. 
 

 Open the saved document. 

 
 Click the File tab on the Ribbon and select Info. 

Information about the document appears. 

 
 Under the Versions section, select the version of 

the file labeled (when I closed without saving). 
 

The file opens. You can choose to restore the file 

or compare it to the previously saved version. 

 

 
 Exercise  

 Exercise File: None required. 
 

 Exercise: Understand how to recover an unsaved 

document.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Figure 16-19: New documents that were closed 

without being saved are temporarily saved. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Click an autosaved version 
to open and restore it. 

 
Figure 16-20: Autosaved versions of a document can be 

found under Versions on the Info tab of Backstage view. 
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 Click Compare or Restore on the Info bar. 
 

Depending on what you choose, Word will either 

overwrite the previously saved version or open a 

new window comparing documents. 
 

Restore earlier versions of the current  
document 
 
You can also restore the file you are working on to 

an earlier version. 
 
 

 Click the File tab on the Ribbon and select Info. 

Information about the document appears. 

 
 Under the Versions section, select the version of 

the file which you would like to view. 
 

The file opens. You can choose to restore the file 

or compare it to the previously saved version. 
 

 Click Compare or Restore on the Info bar. 
 

Depending on what you choose, Word will either 

overwrite the previously saved version or open a 

new window comparing documents. 
 

Tip: Most autosaved versions of your open  
document will be deleted when you close the file. Figure 16-21: When you open an autosaved version of a  

document, you can choose to compare it to the current  
document or to restore the autosaved document.  
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Recording a Macro 
 
A macro is a series of commands and instructions that 

are recorded so that they can be executed as a single 

command. Instead of manually performing a series of 

time-consuming, repetitive actions in Word yourself, you 

can create a macro to perform the task for you. 
 
There are two ways to create a macro: by recording 

them or by writing them in Word’s Visual Basic 

programming language. This lesson explains the easy 

way to create a macro—by recording the task(s) you 

want the macro to execute for you. 
 

Show the Developer tab on the Ribbon 
 
The Developer tab must be displayed on the Ribbon in 

order to access and insert the macro controls. 
 

 Click the File tab on the Ribbon and select Options. 

The Word Options dialog box appears. 

 
 Click the Customize Ribbon tab. 

 
The right column displays the tabs on the Ribbon 

and the groups and commands in each tab. 
 

 Select the Developer check box under Customize the 

Ribbon and click OK. 
 

The Word Options dialog box closes, and the 

Developer tab is displayed on the Ribbon. 

 

Record a macro 
 
When you record a macro, imagine you’re being 

videotaped; everything is recorded—all your commands, 

the data you enter, even any mistakes you make. Before 

recording a macro, it’s helpful to write down a script 

that contains all the steps you want the macro to record. 

Practice or rehearse your script a couple times, to make 

sure it works, before you actually record it. 
 
If you do make a mistake while recording a macro, don’t 

worry—you can always delete the existing macro and try 

again or edit the macro’s Visual Basic source code to fix 

the mistake. 
 

 Click the Developer tab on the Ribbon and click the 

Record Macro button in the Code group. 
 

The Record Macro dialog box appears. 

 
 Enter a name for the macro. 

 
Next you can enter a number of specifications for the 

macro, including assigning a keystroke shortcut to 

the macro for easy access. 

 

 
 Exercise  

 Exercise File: Timesheet15-10.docx 
 

 Exercise: Show the Developer tab on the Ribbon. 
 

Create a macro named “ExpenseReport”. Assign the 

keystroke shortcut <Ctrl> + <Shift> + <Y> to the macro 

and add the description, “This macro automatically fills out 

information for Sandra’s expense reports.” The macro 

should record these commands: 
 

Go to the EmployeeName bookmark. Type “Sandra Wills”, 

press <Tab>, type “10369”, press <Tab>, and insert date 

and time using the Month Day, Year format.  
 
 
 
 
 
 
 
 
 

 
Record Macro 

 
Pause Recording 

 
Macro Security 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Figure 16-22: The Code group on the Developer tab.  
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 (Optional) Click the Keyboard button and press the 

keystroke shortcut that you want to use. Click Close. 
 

If the keystroke is not already assigned to another 

command, [unassigned] appears in the dialog box. 
 

You may also choose if you want to save the macro 

in the current document or template, or enter a 

description for the macro. 
 

 Finish entering the macro information and click OK. 
 

Now the Record Macro dialog box closes, and 

everything you do is recorded. 
 

 Perform the actions you want to include in 

your macro. 
 

You can perform a command from the Ribbon, 

a keystroke shortcut, or a dialog box. 
 

 Tip: You cannot use the mouse to edit and 

select text as you normally would while 

recording a macro—you have to use the 

keyboard instead. You still can use the mouse to 

access the Ribbon, however. 
 

Tip: Use the Pause Recording button if you 

need to stop the macro command progression so 

you don’t have to start all over again.  
 

 Click the Stop Recording button in the Code 

group. The macro is recorded and ready to use. 
 

Other Ways to Stop Recording:  
Click the Stop Recording button on the 

status bar. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Figure 16-23: Enter a macro name that will be easily 

recognizable in the Record Macro dialog box. Include a 

description to make the macro even easier to find.  

 
 
 
 
 
 
 
 

 
Click the Stop Recording button when you 
are finished recording the macro. 

 

Figure 16-24: An example of recording a macro.  
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Playing and Deleting a Macro 
 
Once you have created a macro, you’re ready to use it 

in your documents. 
 

Tips 
 
 If you see a Security Warning message beneath the 

Ribbon telling you that macros have been disabled, 

click the Options button, select Enable this content, 

and click OK.
 

Play a macro 
 

 Click the Developer tab on the Ribbon and click the 

Macros button in the Code group. 
 

The Macros dialog box appears. Here you can see 

the macros that are available in the document. 
 

Other Ways to View Macros:  
Press <Alt> + <F8>. 

 
 Select the macro you want to run and click the Run 

button. 
 

The macro runs, performing the steps you recorded. 
 

Other Ways to Run a Macro:  
Click the button or press the keystroke 

shortcut assigned to the macro. 
 

Delete a macro 
 
Delete a macro when it is no longer needed. This 

lowers the security threat of the document. 
 

 Click the Developer tab on the Ribbon and click the 

Macros button in the Code group. 
 

The Macros dialog box appears. 

 
 Select the macro you want to delete and click the 

Delete button in the dialog box. 
 

Another dialog box appears, asking if you really 

want to delete the macro. 
 

 Click Yes. 
 

The macro is deleted. 

 

 
 Exercise  

 Exercise File: Timesheet15-11.docx 
 

 Exercise: Select cell C3. Run the ExpenseReport macro so 

that Sandra Wills’ information appears in the table.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Figure 16-25: The Macros dialog box displays all 

macros that are available in the document. 
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Editing a Macro’s Visual 

Basic Code 
 
This lesson introduces you to the Visual Basic (also called 

VB or VBA) programming language—the code Word uses 

to record macros. Using the Visual Basic language and the 

Visual Basic editor, you can make minor changes to your 

macros once you have recorded them. 
 
The best way to learn about Visual Basic is to view 

existing code. In this lesson we’ll look at how to view and 

edit the code for an existing macro. 
 

 Click the Developer tab on the Ribbon and click the 

Macros button in the Code group. 
 

The Macros dialog box appears. Here you can see 

the macros that are available in the document. 
 

Other Ways to View Macros:  
Press <Alt> + <F8>. 

 

 Select the macro you want to edit and click the 

Edit button. 
 

The Microsoft Visual Basic Editor program 

appears. Those funny-looking words are Visual 

Basic—the language that was used by Word to 

record the macro you created. 
 

You don’t have to learn Visual Basic to be proficient 

at Word, but knowing the basics can be helpful if 

you ever want to modify an existing macro. If you 

take a close look at the code for your macro, some of 

the procedures should make a little sense to you. For 

example, if your macro contains a copy or paste 

command, you may see the text “Selection.Copy” or 

“Selection.Paste”. 
 

You can delete sections of code to delete certain 

actions from the macro, or edit the code to change 

the macro’s actions. 
 

 Edit the macro’s code as desired, then click the 

Save button on the Standard toolbar. 
 

 Click the Close button in the upper right-hand corner. 
 

The Visual Basic Editor window closes, and the 

Word program window becomes active once again. 

 

 
 Exercise  

 Exercise File: Timesheet15-12.docx 
 

 Exercise: Edit the ExpenseReport macro so that it enters 

“Brad Johnson” instead of “Sandra Wills” and “12561” 

instead of “10369”. 
 

Run the macro to see how it has changed.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Figure 16-26: The Microsoft Visual Basic Editor.  
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