
To Insert Rows: Select the row below where you want the new row to appear. Click the Insert 

command on the Home tab.  The new row appears in your worksheet.  When inserting new 

rows, columns, or cells, you will see the Insert Options button by the inserted cells. This button 

allows you to choose how Excel formats them. By default, Excel formats inserted rows with the 

same formatting as the cells in the row above them. To access more options, hover your mouse 

over the Insert Options button and click on the drop-down arrow that appears.  8 Al- 
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__________________ To Insert Columns: Select the column to the right of where you want the 

new column to appear. For example, if you want to insert a column between A and B, select 

column B.  The new column appears in your worksheet.  By default, Excel formats inserted 

columns with the same formatting as the column to the left of them. To access more options, 

hover your mouse over the Insert Options button and click on the drop-down arrow that 

appears. When inserting rows and columns, make sure you select the row or column by clicking 

on its heading so that all the cells in that row or column are selected. If you select just a cell in 

the row or column then only a new cell will be inserted. Add more than one column or row at a 

time You may already know how to add a column or row, but what if you want to add more than 

one row or column at once, of course you will not repeat the insert command multiple times to 

get the required number of columns or rows, all you have to do is specify the number of rows or 

columns you want Add it, then right-click and insert and you will get the required number. To 

Insert New Worksheets: Click on the Insert Worksheet icon. A new worksheet will appear. You 

can change the setting for the default number of worksheets that appear in Excel workbooks. To 

access this setting, go into backstage view and click on Options. 9 Al- Mustansiriyah University 
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__________________ To Delete Rows: 1. Select the rows you want to delete.  2. Click the Delete 

command on the Home tab.  The rows are deleted from your worksheet.  To Delete Columns: 1. 

Select the columns you want to delete.  2. Click the Delete command on the Home tab.  The 

columns are deleted from your worksheet.  To Delete Worksheets: Worksheets can be deleted 

from a workbook, including those that contain data. Select the worksheet you want to delete. 

Right-click one of the selected worksheet. The worksheet menu appears. Select Delete. The 

selected worksheets will be deleted from your workbook.  Big data selection When it is required 

to specify specific cells in a row or column, we specify by standing on the name of the row or 

column, but in this case the entire row or column is selected To select cells that contain only 

 of a column, use the down arrow To 

Introduction Spreadsheets that have not been formatted can be difficult to read.  Formatted 

text and cells can draw attention to specific parts of the spreadsheet and make the spreadsheet 

more visually appealing and easier to understand. In Excel, there are many tools you can use to 

format text and cells. Hear, you will learn how to change the color and style of text and cells; 



align text; and apply special formatting to numbers and dates. To Add a Border: Select the cells 

you want to modify. Click the drop-down arrow next to the Borders command on the Home tab. 

The border drop-down menu appears.  Select the border style you want to use. You can draw 

borders and change the line style and color of borders with the Draw Borders tools at the 

bottom of the Borders drop-down menu. 10 Al- Mustansiriyah University Collage of Medicine/ 
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__________________ To Change the Font Color: Select the cells you want to modify. Click the 

drop-down arrow next to the font color command on the Home tab. The color menu appears. 

Move your mouse over the various font colors. A live preview of the color will appear in the 

worksheet.  Select the font color you want to use. Your color choices are not limited to the drop-

down menu that appears. Select More Colors at the bottom of the menu to access additional 

color options. To Add a Fill Color: 1. Select the cells you want to modify. 2. Click the drop-down 

arrow next to the fill color command on the Home tab. The color menu appears. 3. Move your 

cursor over the various fill colors. A live preview of the color will appear in the worksheet.  4. 

Select the fill color you want to use. To Change Horizontal Text Alignment: 1. Select the cells you 

want to modify. 2. Select one of the three horizontal Alignment commands on the Home tab. 3. 

Align Text Left: Aligns text to the left of the cell. 4. Center: Aligns text to the center of the cell. 5. 

Align Text Right: Aligns text to the right of the cell.  To Change Vertical Text Alignment: 1. Select 

the cells you want to modify. 2. Select one of the three vertical Alignment commands on the 

Home tab. 3. Top Align: Aligns text to the top of the cell. 4. Middle Align: Aligns text to the 

middle of the cell. 5. Bottom Align: Aligns text to the bottom of the cell.  6. By default, numbers 

align to the bottom-right of cells and words or letters align to the bottom-left of cells. 

Conditional Formatting MS Excel 2010 Conditional Formatting feature enables you to format a 

range of values so that the values outside certain limits, are automatically formatted. Choose 

Home Tab » Style group » Conditional Formatting dropdown. 11 Al- Mustansiriyah University 
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continuation menu with various options for defining the formatting rules that highlight the cells 

in the cell selection that contain certain values, text, or dates, or that have values greater or less 

than a particular value, or that fall within a certain ranges of values. Suppose you want to find 

cell with Amount 0 and Mark them as red. Choose Range of cell » Home Tab » Conditional 

Formatting Drop Down » Highlight Cell Rules » Equal to. After Clicking ok, the cells with value 

zero are marked as red. Top/Bottom Rules: It opens a continuation menu with various options 

for defining the formatting rules that highlight the top and bottom values, percentages, and 

above and below average values in the cell selection. Suppose you want to highlight the top 10% 

rows; you can do this with these Top/Bottom rules. Formatting Numbers and Dates One of the 

most useful features of Excel is its ability to format numbers and dates in a variety of ways. For 

example, you might need to format numbers with decimal places, currency symbols ($), percent 

symbols (%), etc. To Format Numbers and Dates: 1. Click the drop-down arrow next to the 



Number Format command on the Home tab. 2. Select the number format you want. For some 

number formats, you can then use the Increase Decimal and Decrease Decimal commands 

(below the Number Format command) to change the number of decimal places that are 

displayed. 3. Click the buttons in the interactive below to learn about the different number 

formats. To Rename Worksheets: 1. Right-click the worksheet tab you want to rename. The 

worksheet menu appears. 2. Select Rename.  3. The text is now highlighted by a black box. Type 

the name of your worksheet.  4. Click anywhere outside of the tab. The worksheet is renamed.  

To Copy a Worksheet: 1. Right-click the worksheet you want to copy. The worksheet menu 

appears. 2. Select Move or Copy.  3. The Move or Copy dialog box appears. Check the Create a 

copy box.  12 4. Click OK. Your worksheet is copied. It will have the same title as your Al- 
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__________________ original worksheet, but the title will include a version number, such as 

"January (2)". To Move a Worksheet: 1. Click on the worksheet you want to move. The mouse 

will change to show a small worksheet icon . 2. Drag the worksheet icon until a small black 

arrow appears where you want the worksheet to be moved.  3. Release your mouse and the 

worksheet will be moved.  To Color-Code Worksheet Tabs:  1. You can color worksheet tabs to 

help organize your worksheets and make your workbook easier to navigate. 2. Right-click the 

worksheet tab you want to color. The worksheet menu appears. 3. Select Tab Color. The color 

menu appears. 4. Select the color you want to change your tab.  5. The tab color will change in 

the workbook. If your tab still appears white, that is because the worksheet is still selected. 

Select any other worksheet tab to see the color change.  Introduction With over 17 billion cells 

in a single worksheet, Excel 2010 gives you the ability to work with an enormous amount of 

data. Arranging your data alphabetically, from smallest to largest, or other criteria, can help you 

find the information you're looking for more quickly. Hear, you will learn how to sort data to 

better view and organize the contents of your spreadsheet. 13 Al- Mustansiriyah University 
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__________________ Sorting Data in Excel 2010 Sorting is a common task that allows you to 

change or customize the order of your spreadsheet data. For example, you could organize an 

office birthday list by employee, birthdate, or department, making it easier to find what you're 

looking for. Custom sorting takes it a step further, giving you the ability to sort multiple levels 

(such as department first, then birthdate, to group birthdates by department), and more. To 

Sort in Alphabetical Order: Select a cell in the column you want to sort by. In this example, we 

will sort by Last Name.  Select the Data tab, and locate the Sort and Filter group. Click the 

ascending command  to Sort A to Z, or the descending command  to Sort Z to A.  The data in the 

spreadsheet will be organized alphabetically.  Sorting options can also be found on the Home 

tab, condensed into the Sort & Filter command. To Sort in Numerical Order: Select a cell in the 

column you want to sort by.  From the Data tab, click the ascending command to Sort Smallest 

to Largest, or the descending command to Sort Largest to Smallest. The data in the spreadsheet 



will be organized numerically.  Select the data that you want to sort  *Select a range of data, 

such as A1:L5 (multiple rows and columns) or C1:C80 (a single column). The range can include 

titles that you created to identify columns or rows. *Sort quickly  1. Select a single cell in the 

column on which you want to sort.  2. Click to perform an ascending sort (A to Z or *Sort by 

specifying criteria  You can choose the columns on which to sort by clicking the Sort command in 

the Sort & Filter group on the Data tab. 1.Select a single cell anywhere in the range that you 

want to sort.  2.On the Data tab, in the Sort & Filter group, click Sort.  The Sort dialog box 

appears. 3. In the Sort by list, select the first column on which you want to sort.  4. In the Sort 

On list, select either Values, Cell Color, Font Color, or Cell Icon.  5. In the Order list, select the 

order that you want to apply to the sort operation — alphabetically or numerically ascending or 

descending (that is, A to Z or Z to A for text or lower to higher or higher to lower for numbers 14 
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__________________ To Sort by Date or Time: Select a cell in the column you want to sort by.  

From the Data tab, click the ascending command to Sort Oldest to Newest, or the descending 

command to Sort Newest to Oldest. The data in the spreadsheet will be organized by date or 

time.  Protect Worksheet You may want to protect a worksheet for a variety of reasons. One 

reason is to prevent yourself or others from accidentally deleting the formulas or other critical 

data. A common scenario is to protect a worksheet, so that the data can be changed, but the 

formulas can’t be changed. To protect a worksheet, choose Review » Changes group »Protect 

Sheet. Excel displays the Protect Sheet dialog box. Note that providing a password is optional. If 

you enter a password, that password will be required to unprotect the worksheet. You can 

select various options in which the sheet should be protected. Suppose we checked Format Cells 

option then Excel will not   allow to format cells.  When somebody tries to format the cells, he or 

she will get the error as shown in the screenshot. To unprotect a protected sheet, choose 

Review » Changes group » Unprotect Sheet. If the sheet was protected with a password, you’re 

prompted to enter that password. Page Layout tab Background: used for adding picture to the 

worksheet. Heading: Click on view icon found in heading to Show column heading or hid it. 

Gridlines: Click on view icon found in gridlines to Show or hid the lines between row and 

column. MS Excel provides various sheet options for printing purpose like generally cell gridlines 

aren’t printed. If you want your printout to include the gridlines, Choose  Page Layout » Sheet 

Options group » Gridlines » Check Print Options in Sheet Options Dialogue Print Area: You can 

set the print area with this option. Print Titles: You can set titles to appear at the top for rows 

and at the left for columns. o Gridlines: Gridlines to appear while printing worksheet. o Black & 

White: Select this check box to have your color printer print the chart in black and white. o Draft 

quality: Select this check box to print the chart using your printer’s draft-quality setting. . 

Change the direction of worksheet 1. To change the direction of the worksheet, click on: 2. 

Select Page layout tab 3. Choose Sheet right - to- left  Sheet right-to-Left: switch the sheet 

direction from right to left.  15 Al- Mustansiriyah University Collage of Medicine/ Department of 
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__________________ View tab This bar provides different options for viewing the sheets in an 

Excel workbook. It also provides options for viewing different windows in Excel, for enlarging or 

reducing the size of the worksheet while it is being viewed, and what elements in the Excel 

window should be displayed. *Workbook Views: -Excel offers 4 types of workbook views: - 

Normal, Page break preview, Page layout & Custom View. We use “Normal” option to see the 

normal view of Excel. We use Page break preview option to see that where the page-breaks 

appear when we print the document. Through “Page layout” option, we can check from where 

does the page begin and end as well as to see any header / footer on the page. We use Custom 

View option to save the current display and setting as a custom view which we can apply in 

future. *Show: - We use this option to show and hide the Excel’s view. Ruler is used to show the 

rulers next to our documents. Grid lines option is used to show the lines between rows and 

columns in the sheet to make the sheet easier to read. Through Formula bar, we can obtain the 

formula for the active cell. Heading is used to show the heading of columns and rows number. 

*Zoom: -We can adjust the view as per our convenience. Zoom 100% is the standard view for 

viewing the Excel file. We use Zoom to selection to zoom the sheet so the selected range of cells 

fills the entire window. Spell Check MS Excel provides a feature of Word Processing program 

called Spelling check. We can get rid of the spelling mistakes with the help of spelling check 

feature. Spell Check Basis Let us see how to access the spell check.  To access the spell checker, 

Choose Review ➪ Spelling or press F7. To check the spelling in just a particular range, select the 

range before you activate the spell checker. If the spell checker finds any words it does not 

recognize as correct, it displays the Spelling dialogue with suggested options. Let us see the 

various options available in spell check dialogue. Ignore Once: Ignores the word and continues 

the spell check. Ignore All: Ignores the word and all subsequent occurrences of it. Add to 

Dictionary: Adds the word to the dictionary. Change: Changes the word to the selected word in 

the Suggestions list. Change All: Changes the word to the selected word in the Suggestions list 

and changes all subsequent occurrences of it without asking. AutoCorrect: Adds the misspelled 

word and its correct spelling (which you select from the list) to the AutoCorrect list. 16 Al- 
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__________________ Info status bar It is possible to easily know the outputs of several 

equations for specific values in cells through the status bar. Freeze panes When the data is too 

large, moving between rows and columns leads to the disappearance of the main row as well as 

the main column to avoid this case, we select the first cell and then from the view menu we 

choose freeze panes 17 


